Noua eroare de securitate Safari pe Mac, cum ar trebui să vă protejați?

În ultimele ore, un defect important de securitate a fost descoperit pe Mac-uri. Mai precis, în browser Safari implicit . Deși este adevărat că la început trebuie să spunem că echipamentul în sine sau datele de natură extrem de sensibilă nu sunt în pericol, există anumite informații legate de activitatea dumneavoastră care ar putea fi făcute publice de unele site-uri web.

Noua eroare de securitate Safari pe Mac

Care este acest defect de securitate?

Site-ul specializat în căutarea vulnerabilităților, FingerprintJS, a avertizat într-un a intrare recentă a unui bug în programarea Safari, adică permițând site-urilor web să urmărească activitatea utilizatorului, indiferent de setările browserului pe care utilizatorul le-a ales. Pentru că, după cum probabil știți deja, pentru mai multe versiuni browserul vă permite să împiedicați urmărirea pe site-uri web, dar, din păcate, acest lucru este ignorat din cauza acestei erori plictisitoare.

Problema, conform blogului menționat mai sus, constă într-o problemă de implementare a WebKit în API-ul „IndexedDB”, un API JavaScript care este de obicei folosit de unele site-uri web pentru a accesa informații personale, cum ar fi activitatea recentă în browser sau chiar fotografia de profil care este folosit în Google. Desigur, după cum este evident, nu toate site-urile web pot accesa aceste informații, dar cele care folosesc API-ul menționat mai sus pot.

Prin urmare, așa cum am spus la început, puteți sta liniștit în ceea ce privește stabilitatea computerului dvs. Nu există niciun program malware care să îl facă inutilizabil sau care să poată fura informațiile pe care le-ați stocat pe el. Nici măcar nu vor putea accesa date precum cardurile de credit sau altele asemenea. Cu toate acestea, aceștia vor putea să vă urmărească istoricul în scopuri comerciale, care de obicei necesită acordul dvs.

Creați grupuri de pestañas în safari

Cum poți evita să fii o victimă?

Ar fi la fel de simplu ca să-ți spun să nu vizitezi pagini web care folosesc API-ul IndexedDB, dar logic nu este ceva ce poate fi cunoscut la început și chiar dacă ar fi, ar fi o soluție prea plictisitoare. De aceea se recomandă să utilizați alte browsere pentru Mac , deoarece eroarea provine din Safari și nu din alte browsere. Cel puțin din ceea ce se știe în prezent. De remarcat că și în versiuni vechi de Safari precum „14”, această problemă nu este prezentă.

Soluția definitivă va veni cu un actualizare de către Apple , fie la nivel de sistem oferind o versiune ipotetică de macOS 12.1.1, fie cu una dintre cele cunoscute ca actualizări complementare și care ar actualiza doar browserul. Deocamdată nu există nimic din toate acestea și nici compania californiană nu a vorbit. Totuși, având în vedere zgomotul pe care îl generează această știre, este mai mult decât probabil să fie deja la curent și să lucreze la corecția de securitate pentru a o remedia.