Com essas duas funções do Excel você sempre terá as contas

sobressair é um dos programas mais completos para criar planilhas que podemos encontrar. Com ele poderemos realizar todo tipo de operações e funções. E ainda, graças ao seu potencial, podemos até trabalhar com um grande número de decimais para obter resultados o mais precisos possível. No entanto, na maioria das operações não precisaremos, por exemplo, de 10 casas decimais, e será suficiente para nós, e será mais confortável, trabalhar com duas ou três.

Com essas duas funções do Excel você sempre terá as contas

O problema que podemos encontrar ao trabalhar com duas ou três casas decimais é que estamos perdendo informações. Se optarmos pelo arredondamento, por exemplo, estaremos somando um valor que de fato não existe, enquanto se optarmos pelo truncamento, estaremos perdendo um valor que, a longo prazo, pode acabar alterando os resultados.

Assumindo esses possíveis problemas que podemos encontrar, a seguir veremos como utilizar essas duas funções.

Números arredondados com base no decimal

A primeira coisa que vamos ver como fazer no Excel é arredondamento. Como já explicamos, ao escolher esta opção, o que estamos fazendo é que o programa leia um decimal específico de uma posição e, se for igual ou maior que 5, adicione um ao decimal anterior, enquanto se for menos, deixa como está.

Para esta tarefa vamos usar o Função REDONDO. Devemos indicar a esta função o número (ou a célula) que queremos arredondar, bem como o número de casas decimais que queremos obter no número resultante. Portanto, a função será a seguinte, onde A1 é a célula a ser arredondada e N o número resultante de casas decimais:

=REDONDEAR(A1;N)

Excel função redondear

Outra forma de o fazer, sem recorrer a esta função, é utilizando um botão que aparece na barra de ferramentas. Este botão se encontra especificamente na seção “Número” e nos permite ajustar as casas decimais que queremos que nosso número tenha com um clique.

Botón Excel mais menos decimais

Truncar no Excel: ajustar sem arredondar

Se não queremos que as cifras subam e queremos obter o valor mais preciso possível, podemos optar por truncar o valor . Usando o função TRUNCATE, o que obtemos é que o Excel corta o número em um determinado decimal, mas ignora o valor do próximo decimal. Desta forma, se o decimal seguinte for maior ou igual a 5, não será adicionado um ao decimal anterior, mas o mesmo valor será mantido como está.

Esta fórmula é muito semelhante à fórmula de arredondamento. Ou seja, devemos primeiro indicar o número, ou a célula, que queremos truncar, e depois indicaremos o número da casa decimal onde vamos cortar. Desta forma, tendo em conta que A1 é a célula onde se encontra o valor, e N o número de casas decimais, a fórmula é a seguinte:

=TRUNCAR(A1;N)

Como podemos ver, no nosso caso, alguns dos valores (especificamente, aqueles cuja quarta decimal foi menor que 5) permanecem os mesmos com ambas as funções, enquanto aqueles cuja quarta decimal foi maior ou igual a 5, são maiores ao arredondar que ao truncar

Excel redondear vs truncar

Agora, dependendo do tipo de operação que estamos realizando no Excel, podemos escolher uma função ou outra.