Zeer binnenkort zullen duizenden Google Chrome-extensies niet meer werken

Dankzij de extensies van webbrowsers, zoals Google Chrome , kunnen we de browse-ervaring verbeteren met functies die standaard niet beschikbaar zijn in deze programma's. We kunnen bijvoorbeeld de beveiliging en privacy verbeteren, het uiterlijk van sommige websites veranderen en zelfs hun functies verbeteren of de toegang tot bepaalde diensten, zoals e-mail of sociale netwerken, vergemakkelijken. Om al deze redenen zijn extensions een belangrijk onderdeel van ons dagelijks leven geworden. Hoewel dit zeer binnenkort ten kwade zal veranderen.

Een extensie werkend krijgen in de browser, en ook nog eens probleemloos en met inachtneming van de regels van Google of Mozilla, is een ingewikkelde opgave waar veel werk aan zit. Daarom is het alleen slecht nieuws voor ontwikkelaars als er wijzigingen zijn in de voorwaarden van de extensieopslag, of erger nog in de browser-API.

duizenden Google Chrome-extensies werken niet meer

Als we terugkijken, een paar jaar geleden, besloot Mozilla het formaat van extensies te veranderen in Webextensie, letterlijk 100% van de ontwikkelaars dwingen om hun extensies opnieuw te updaten en te maken, waardoor hun functionaliteiten worden verminderd. Nu gebeurt er weer iets soortgelijks met Google, en dat is dat de persoon die verantwoordelijk is voor Chrome zijn nieuwe en controversiële, manifesteren v3 , die ontwikkelaars veel kopzorgen bezorgt.

Manifest v3: zo zullen extensies voor altijd veranderen

Als alles volgens plan verloopt, is Google van plan om Manifest v3 verplicht te maken voor extensies vanaf januari 2023 . Dit betekent dat ontwikkelaars die hun extensies niet hebben bijgewerkt volgens de nieuwe regelgeving, ze uit de winkel zullen zien verwijderen. Bovendien kunnen extensies die tussen nu en januari 2023 niet zijn bijgewerkt, niet meer worden bijgewerkt en moeten hun ontwikkelaars ze opnieuw uploaden en helemaal opnieuw beginnen.

Normaal gesproken worden verlaten extensies niet bijgewerkt. Daar rekenen we allemaal op. Maar wat niet zo normaal is, is dat Google nieuwe API's heeft beloofd aan ontwikkelaars en niet nakomt wat is beloofd. Zonder deze API's zijn veel functies die zouden kunnen worden aangeboden via de huidige Manifest v2 onmogelijk te implementeren in de nieuwe v3, dus duizenden extensies zullen niet kunnen blijven werken.

Sommige van de extensies die in dit opzicht het meest worden beïnvloed, zijn bijvoorbeeld de extensies voor het blokkeren van proxy en webinhoud .

Chrome-extensies proxy

Er zijn amper 3 maanden over en duizenden extensies, waarvan vele zelfs erg populair, zijn onmogelijk te updaten en garanderen gebruikers dat ze normaal blijven functioneren. Sommigen hebben zelfs al een versie met Manifest v3 voorbereid, maar om zich aan deze regelgeving aan te passen, hebben ze zoveel functies geëlimineerd dat ze zelfs nutteloos zijn geworden.

We herinneren ons dat de deadline waarin Google extensies zal dwingen om Manifest v3 te gebruiken, en alle extensies die zijn aangepast voor V2 niet meer zullen werken, in januari 2023 is. Natuurlijk zal Chrome een administratief beleid hebben voor bedrijven waardoor deze extensies blijven werken voor nog 6 maanden, tot juni 2023. Maar daarna kunnen zelfs bedrijven niet meer werken met Manifest v2.

Firefox, en andere browsers (zoals opereren) hebben aangekondigd dat ze met V3 niet in de voetsporen van Google zullen treden. Het kunnen interessante alternatieven zijn om te migreren voor het geval we enkele extensies missen.